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I deactivated my SIM and activated it again, but it is not working

Check and clear the FPLMN list on the SIM.

Jakub Kubinski avatar
Written by Jakub Kubinski
Updated over 10 months ago

Environment

  • Onomondo app:

    • Network Logs

    • Signaling Logs

  • Device: applicable to all

Issue

  1. SIM cards were deactivated for a longer period of time.

  2. Upon re-activating, the device would not connect again.

  3. Network Logs do not display new activity.

  4. Signaling Logs display either:

    1. No new activity

    2. invoke updateLocation responds with returnError
      (error code: operatorDeterminedBarring)

​Solution

Clear the forbidden (FPLMN) list on the SIM. You can either:

  • clear the list manually with AT commands;

  • enable manual network selection mode with AT+COPS;

  • remove and reinsert the SIM into the device;

  • insert the SIM in a phone; or

  • wait until the device moves across borders.

You can read the full manual on how to clear FPLMN here.

Cause

If a SIM is deactivated and the device tries to connect - the device will write all networks it tries authenticating with onto the FPLMN list on the SIM. This is a standard practice. Unless the device firmware has embedded logic for automatic FPLMN clearing, the issue has to be resolved by manual clearing.

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