Environment
Onomondo app: Network Lists
Question
Why is network X not available in country Y?
Can you add network X to your coverage page?
Are you seeking commercial arrangements with operators in country Y?
Answer
Currently supported networks are listed on our Coverage Page.
Availability of networks and supported technologies depends on commercial agreements with operators, as well as the extent of infrastructure deployments.
If a local operator is not listed - it means that there is no agreement in place.
The selection of networks in the Network Marketplace is in line with the Coverage Page.*
*Free Trial users are limited to networks listed under Free Trial software package.
Cause
We are always working on expanding our coverage, but contract negotiations with Mobile Network Operators tend to take time and effort.