Environment
Onomondo app:
Network Logs
Signaling Logs
Device: applicable to all
Issue
I have inserted the SIM into my device, but I see no activity in Network Logs and/or Signaling Logs.
The logs are empty.
Resolution
The device is not actively trying to connect to the network. You have to:
Make sure that these device settings are correct:
APN set to: onomondo
Data roaming set to: enabled
Network selection mode set to: automatic
Make sure that there is coverage in the area for at least one of the modem technologies
Cause
There could be multiple causes why the device is not connecting to the network. Following the above steps ensures that the connections is established correctly.
Signaling Logs display all communication between the local RANs (Radio Access Networks) that device is connected to and Onomondo. These are displayed in real time. If we see no packets coming to Onomondo, it's most likely due to the fact that the device is not connected to the local network.
Network Logs translate Signaling Logs into simple events that directly correspond to the activity seen in signaling. These are also displayed in real time.
If you are not getting the expected results - reach out to [email protected]. Please provide the details of the problem, any logs from your tests, as well as contextual information, e.g. what device and modem are you using. The more information we have, the better we can work together to solve your issues.
When a device connects to a network there is a lot of signalling information between the RAN and Onomondo.