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I can't send SMS to my device due to absentSubscriber error

Make sure your device is registered to the network on GSM.

Jason Godfrey avatar
Written by Jason Godfrey
Updated over a week ago

Environment

Issue

  • I can't send SMS to my device. SMS console shows error: absentSubscriber.

  • I am finding that SMS is not sent even when the device is online and sending data.

  • The SMS console displays absentSubscriber errors. What does it mean?

Solution

Make sure your device is registered to the network on GSM.

  1. Check if your device is capable of handling SMS.

  2. Issue AT+CREG? to check the GSM registration status.

  3. If the response is "5", try sending SMS again.

  4. If the response is different, try rebooting the modem.

Workaround

If you can't access your device and connectivity is lost - wait for the SMS to be retried.

You can also troubleshoot the device attaching to the GSM network if you are not seeing any "GSM" Network Logs in the Onomondo app.

Cause

Failed SMS attempts normally resolve automatically between the local operator and Onomondo Core Network during the next network registration on GSM.

The absentSubscriber error coming from the local operator indicates that the network cannot locate the device in the system that handles SMS routing, even though the device may be attached to the network for data services.

In this case, the local operator will inform the Onomondo Core Network next time the device registers to the GSM (also known as the Circuit Switch part of the network).


This can be seen either in:

  1. Network logs - attached GSM connection on...

  2. Signalling logs - invoke ReadyForSM message, if the device is already registered and ready to receive SMS again.

In both of these circumstances, Onomondo SMS Center (SMSC) will retry the SMS. The SMSC also has a fallback, where it retries an SMS once every two hours (up to 10 times).

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