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My device cannot connect on LTE-M / NB-IoT and there are no Network Logs
My device cannot connect on LTE-M / NB-IoT and there are no Network Logs

Check your device configuration and timeout settings for optimal connectivity

Jakub Kubinski avatar
Written by Jakub Kubinski
Updated over 2 weeks ago

Environment

  • Onomondo App: Network Logs

  • Device: Applicable to all devices without NB-IoT and LTE-M support

Issue

  • There are no network logs for the specified time period.

  • No previous network logs have been recorded.

  • N.B. The device does not support NB-IoT or LTE-M connectivity.

Solution

  • Check Device Configuration: Ensure that your device is correctly configured for connecting to the Onomondo network.
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  • Review Timeout Settings: If you are using a pre-configured device that previously had another SIM, verify the timeout settings on the device. For optimal performance during initial testing, set the timeout to approximately 2-3 minutes. This helps reduce connection delays and provides a low timeout rate.
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  • Monitor Connection Attempts: If the device is not attempting to connect to the Onomondo network, investigate potential issues in the device/module configuration that could be hindering the connection.

Cause

The reason you might experience longer connection times during the first attempt is that Onomondo does not use preference lists, which means the device connects based on signal quality rather than pre-defined network priorities. After the initial connection, the module writes this information to the SIM and often caches it in memory, resulting in improved connection times for subsequent attempts.

"We are not seeing the device attempt to connect to a network."

Normally this is caused by something in the device/module configuration that is slowing down the connection. First check if NB-IoT and LTE-M are enabled.
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"We are seeing the device just take longer if NB-IoT is enabled in countries where we don't have access to NB-IoT."

Try disabling NB-IoT on the device and see if the connection improves. Otherwise check that the bands as well as the timeout time for the connection attempt. During early testing we recommend setting the timeout around 2-3 minutes. This should give you a low timeout rate. The reason why you might see it taking longer for the first time the device connects is because most other SIM providers use a Perferred Network list (PLMN) or only connect to a home network. This speeds up the connection time but forces the device to connect to a network based on their priortization and not the quality of the signal strength. As a result, a device will at times pick a higher priority network with weak signal. We don't use the PLMN lists so the device searched for any network (that is on the network list) with good signal. After the initial connection, the module will store the network attachment so the SIM tries to attach to the same network next time.
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