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My device cannot connect and I see returnError: "OperatorDeterminedBarring" in Signaling Logs
My device cannot connect and I see returnError: "OperatorDeterminedBarring" in Signaling Logs

Review the FPLMN list and perform a full scan to ensure optimal connectivity.

Jakub Kubinski avatar
Written by Jakub Kubinski
Updated over a year ago

Environment

  • Onomondo App:

    • Signaling Logs

    • Network Logs

  • Device: Applicable to all

Issue

  • My device is trying to connect, but I do not see any new Network Logs.

  • Last Signaling Logs show returnError: "OperatorDeterminedBarring".

  • The device might have been deactivated or forbidden from connecting.

Solution

  1. Check and clear the FPLMN List, if necessary.

  2. Perform a full network scan with AT+COPS=?.

    • This command will scan for all available networks and technologies. It will also provide the network status.

    • If the network status shows a "3" it means that the network is marked as "forbidden" by the device and will no longer attempt to connect to it.

Cause

When a device receives a denial from a network, such as "OperatorDeterminedBarring" or "Roaming Not Allowed," the cellular module adds that network to the FPLMN list, which prevents further attempts to connect to that network. This list is typically stored in both the device memory and on the SIM card.

If you are still having issues, you are welcome to reach out to us at [email protected].

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