Skip to main content
All CollectionsTroubleshooting guides and FAQsNetwork selection & network coverage
Why is there no data in Cell Tower Location Information?

Why is there no data in Cell Tower Location Information?

Cell Tower information is provided when captured in signalling. Location is retrieved and limited to data of external geo-location services.

Jakub Kubinski avatar
Written by Jakub Kubinski
Updated over a month ago

Environment

  • Platform SIM page

  • SIMs API responses

  • Device logs

Question

  • Why is there no data in Cell Tower Location Information when my device is registered to a network?

Answer

Cell Tower information is provided when captured in signalling when the device comes online. Location is retrieved using this information and limited to what is available of the external geo-location services used.

Cause

Cell Tower location information is only provided during the communication between local operator and Onomondo Packet Gateway (PGW), which manages the data session connection. A device is considered online on the platform when a data session is active between operator and PGW. If the modem has registered to a network in network logs but no data attach log is seen, then the SIM is not considered "online" and no Location information has been received.

If the information is being compared directly with modem/device logs, there can be a difference as modem displays location information earlier in the registration process.

Once the location information has been retrieved from the signalling, our location service queries geolocation services to identify a coordinates of the cell tower. Sometimes the response from the service can be cell tower not found or the coordinates are inaccurate.

Did this answer your question?