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I see 0 byte sessions when using NB-IoT

When the device is attached to NB-IoT there is no data in the data sessions on the platform make sure to check that ePCO is disabled.

Jason Godfrey avatar
Written by Jason Godfrey
Updated over a month ago

Environment

  • Onomondo App: Network Logs

  • Device: Applicable to all devices with NB-IoT enabled

Issue

  • On the device

    • The device registers to NB-IoT network but fails to send data

  • In the app

    • There are "Attached..." and "Detached data connection" events in Network Logs

    • The "Detached..." data log shows 0 bytes for both Download and Upload

Solution

Check if ePCO is disabled. This AT Command is often proprietary and therefore changes between modules. It is best to consult the modem manufacturer's AT command manual for the correct command.

Example - the Nordic nRF91 series:

You can use AT%XEPCO? to check the modem's current ePCO configuration.

If the response is %XEPCO: 1, then you need to change it to AT%XEPCO=0 and try to connect to the network again.

Cause

Currently, Onomondo Packet Gateway does not support the ePCO protocol. When ePCO is enabled the IP configuration of the session is sent empty. This results in missing information provided in the configuration of the session (including IP address, DNS IPs, etc) and as a result the device looks online, but is unable to send any data.

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