Environment
Onomondo Core Network
Onomondo app: Network Logs
Operator: Vodafone Spain
Cellular technology:
LTE
LTE-M
NB-IoT
Issue
My device cannot send data when attached to Vodafone Spain LTE network.
Network Logs show zero byte sessions when "detached data connection" from Vodafone Spain (214-01).
I'm not receiving data, although the SIM is connecting to Vodafone Spain.
Solution
To avoid issues, limit enabled technologies to 2G/3G, either on device level or SIM level.
For specific information on how to set technology preferences on the module - consult your hardware manufacturer and/or the dedicated AT command manual.
Workaround:
Remove Vodafone Spain from your Network List and use another network if possible.
Warning: Removing Vodafone Spain from your Network Lists might lead devices to write this operator onto the FPLMN list on the SIM, which can pose connectivity issues.
Cause
The issue stems from extra header information added by the local serving gateway.
This can cause data packets to be dropped by Onomondo's packet gateways, resulting in connectivity problems like being unable to ping external servers.
The issue is limited to LTE and its sister technologies, specific to Vodafone network.
2G/3G works fine.
There is no set resolution timeline, but we are working on implementing updates to our packet gateway that would overcome the problem with added headers.