Skip to main content

My Free Trial SIM is getting rejected by the network.

Free Trial SIMs have limited network access; some operators are excluded from the Free Trial plan.

Customer-Success avatar
Written by Customer-Success
Updated over a week ago

Environment

Issue

  • I can't connect to networks that are on the Coverage page.

  • Device cannot connect to specific local networks while using a free trial SIM.

  • Other networks in the same area are accessible.

  • Why is network X excluded from the Free Trial?

  • My free trial SIM does not work on network X.

  • My device is attempting to connect but cannot open data session.

  • I see in the Network Logs that network X is barred / rejected due to "network_whitelist".

  • I have inserted the free SIM, but the device is not registering to the network..

Solution

Free Trial accounts are limited to selected networks:

  • Not all local operators are included in the Free Trial package.

  • To see which networks are supported under the Free Trial, visit the Coverage Page and select the “Free Trial” coverage plan.

  • For full network access, consider upgrading to a paid subscription.

Cause

The Free Trial subscription offers access to most affordable networks, ensuring that you have at least one option in each country to test. However, the SIMs are subject to a limited set of roaming agreements. If a local operator is not included in the free trial coverage plan, devices using trial SIMs will not be able to register on that network. Full access is available with a non-trial (paid) account.

Did this answer your question?