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Why does my device keep trying to connect to a network not included in the Network List, even though other operators should be available in the area?

This can depend on many factors.

Jakub Kubinski avatar
Written by Jakub Kubinski
Updated over a month ago

Environment

  • Device: applicable to all

  • Onomondo app:

    • Network Lists

    • Network Logs

Question

  • Why does my device keep trying to connect to a network not included in the Network List, even though other operators should be available in the area?

  • I see repeated "Not allowed to connect" events in the Network Logs, all pointing to a single operator. There are other operators in the area which the device should have access to. Why does it not attempt attaching to those?

Answer

This can depend on many factors:

  • Network congestion,

  • Network temporarily unavailable,

  • Poor network signal,

  • Pre-set PLMN preferences on the modem (if any),

  • Recent Network List updates have not taken effect yet.

Cause

It is possible that the local operator may be prioritizing "home" SIMs over "foreign" / roaming SIMs under highly congested traffic conditions. This can happen when many devices within the same area are trying to join the network at the same time, fx. in urban areas with many active subscribers and infrastructure unable to handle all traffic at once. If the operator is rejecting the connection attempts before the request reaches Onomondo, we would not see it on our side (in Signaling Logs).
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Any evidence from the modem could help us understand what is happening and why it seems that your device is only trying networks not included in the Network List.

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