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Is my SIM damaged?

Try these steps to verify whether SIM card has incurred damage.

Jakub Kubinski avatar
Written by Jakub Kubinski
Updated this week

Environment

  • SIM form factor:

    • Plastic SIM

    • MFF2 SIM chip

  • Device: applicable to all

Issue

  • I have inserted the SIM into the device but it's not recognized.

  • The SIM is not visible when inserted into the device.

  • The phone shows "no service" and I cannot connect to any network.

  • I inserted the SIM into the device and I received a notification that the SIM is invalid. The device works fine with another SIM.

Solution

If you can issue AT commands:

  1. Insert the SIM and power on the modem.

  2. Check AT+CPIN and/or AT+CCID.

    • The modem should return +CPIN: Ready and/or +CCID: [ICCID number].

  3. If the above returns Error, try placing the SIM in a different modem and repeat the steps.

    • Alternatively, try with a mobile phone (see: Workaround).

  4. If the SIM was recognized - test connectivity.

If all of the above fails and the SIM is not recognized - the SIM could be damaged and might need replacing.

It's worth keeping an eye on the Network Logs during the process. The logs offer real-time insights into your device's connection attempts.

Workaround

If you are using a mobile phone:

  1. Insert the SIM and power on the mobile phone.

  2. Go to network settings.

  3. Set the APN to: onomondo.

  4. Toggle automatic network selection.

  5. If nothing happens, manually search for available networks.

  6. See if the phone can register with any network.

  7. Once connected, go to a mobile browser and see if you can view any webpage, fx. onomondo.com.

If the phone still shows "no service", the SIM could be damaged and might need replacing.

Cause

SIM damage can occur due to overheating inside the device or an electric short circuit, even if there are no visible signs of external damage. If you suspect your SIM is damaged, try inserting it into multiple devices to confirm its functionality.

If the SIM has never been used, stored properly, and you suspect a factory flaw - please reach out to us via chat or email at [email protected].

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