Skip to main content

Device is online on platform but does not respond to my ping

Your device is not responding because it is configured not to answer pings or has down a hard shut down

Jason Godfrey avatar
Written by Jason Godfrey
Updated over 2 weeks ago

Environment

  • OpenVPN

  • Onomondo app:

    • Traffic Monitor

    • SIM page

  • Device: applicable to all

Issue

  • When we attempt to ping the SIM IPs, the requests keep timing out, despite the Onomondo portal indicating that the SIMs are online.

Solution

  1. Ping the device.

  2. Check Traffic Monitor on the individual SIM page.

  3. If there are packets in traffic monitor sent to the device, but the device is not responding

    1. Check device/router configuration*.

    2. Check whether the device is online on the SIM Page of the App.

    3. Check if the device has power cycled modem.

  4. If there are no packets in the traffic monitor

    1. Check OpenVPN connection is setup correctly.

    2. Check user access level of user with OpenVPN connection has access to SIM.

*consult your device manufacturer for help with this step.

Cause

To ping a device you need to have an OpenVPN connection to the device. This includes making sure that the user access levels are correct to access the specific SIM. A user needs to be either admin or a member with a tag shared with the SIM. If it is the OpenVPN connection or user access settings the PING will not reach the traffic monitor service.

If there is ICMP traffic (related to a PING) going to the SIM's IP address, that means that the OpenVPN connection is correctly configured. The traffic monitor will still see packets in the traffic monitor even if there is no active data session between device and Onomondo Core.

When the device is online on the Onomondo App, then there is an open session. However, when a modem is power cycled or the pin to the modem is pulled, it does not inform the local operator that is closing the connection, as a result the SIM page will still report the SIM incorrectly online until:

  1. local operator closes the session.

  2. Onomondo Core closes connection due to inactivity after 48 hours.

  3. Device makes a new connection and opens a new session.

Some devices/routers can be setup up to ignore / not respond to PINGs. In this case the device would be online and able to send data but is not responding to PINGs due to the configuration/setup.

Did this answer your question?