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Is there a monthly or periodic fee per SIM?

Yes, a tech fee may apply per SIM, depending on your commercial agreement.

Written by Chandika Ambawatte
Updated over 3 weeks ago

Environment

  • Subscription type:

    • Pro

    • Fleet

    • Enterprise

  • SIM type: applicable to all

Question

  • Is there a monthly or periodic fee per SIM?

  • Is the cost per SIM, usage-based only?

  • Are there any monthly or recurring fees per SIM?

  • Are there fixed costs per SIM in addition to usage charges?

Answer

Yes, there is a monthly Tech Fee.

The Tech Fee is defined in your commercial agreement; please refer to that document for the specific rate that applies to your account.

If you’re unsure about your Tech Fee, please contact your Customer Success Manager (CSM) for clarification.

Note that Tech Fees do not apply to customers on Free Trial or Sandbox subscription plans.

Cause

The Tech Fee reflects infrastructure and support costs tied to maintaining each SIM.

The applicability of the Tech Fees depends on the structure of your contract with Onomondo. The Tech Fees can apply either to SIMs transmitting data -- where you pay only for those that are actively being used -- or active SIMs -- all those that are activated in the Onomondo app, regardless of actual usage.

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