Skip to main content

I disconnected the modem from power but the SIM is still "online" in the Onomondo app.

Power down the modem according to manufacturer's recommendations. This should help ensuring that SIM online status is up to date.

Jakub Kubinski avatar
Written by Jakub Kubinski
Updated this week

Environment

  • Device: externally powered cellular module

  • Onomondo app:

Issue

  • I disconnected the modem from power but the SIM is still "online" in the Onomondo app.

  • I disconnected the power cable from the device where the SIM card is inserted but it still shows online in the portal.

  • I do not see "Detached data connection" in the Network Logs, although the device was turned off.

Solution

Power down the modem according to manufacturer's recommendations. This should help ensuring that SIM online status is up to date.

Cause

​Normally, when you power down the modem or trigger a soft reset, the modem would perform a standard disconnect procedure and inform the local operator that it's detaching from the network.

This would result in a "Delete session request" sent to Onomondo and Onomondo replying with "Delete session response" in signaling, which instantly updates the SIM online status.

If the modem is disconnected from power abruptly (e.g. by pulling out the power cable) - there is no chance to perform the disconnect procedure, hence - Onomondo never gets notified the device is detaching from the network and assumes it's still online. In case of no activity during a currently ongoing session - the SIM might still remain "online" for up to 48 hours. This is how long we keep the data sessions open on the network.

Did this answer your question?