Skip to main content

I cannot see the IMEI on the SIM page

IMEI is only reported once the device comes online. However, it is not guaranteed to be reported.

Written by Jakub Kubinski

Environment

  • Onomondo app: SIMs

  • Onomondo API: GET SIMs

Issue

  • I cannot see the IMEI on the SIM page.

  • The IMEI is empty.

  • I cannot find my SIM with the IMEI number.

Solution

If you cannot see or find the IMEI associated with the SIM, it is likely that the device have never come online.

Use ICCID to identify your SIMs instead.

Cause

Onomondo can only retrieve the IMEI from the device once the device actually attaches to the network. The IMEI is provided to us via signaling sent from the local RAN.

If the device has come online but you still cannot see the IMEI, it is likely that the local Serving Gateway (SGW) has never disclosed it in signaling. The inclusion of IMEI in GTPv2 signaling is optional, according to telco standards (3GPP TS 29.274), and some operators might choose to exclude it.

Did this answer your question?